aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Davis <jdavis@postgresql.org>2024-08-20 11:24:00 -0700
committerJeff Davis <jdavis@postgresql.org>2024-08-20 12:25:06 -0700
commit0fb0f689331cb0c00348aab752dced30493a6672 (patch)
treecb0a47cfc1f86c36f9bda4378335b82118ce7359 /configure.ac
parent5ff9b6b4d981a59236a89d33dea8bc253257ce2a (diff)
downloadpostgresql-0fb0f689331cb0c00348aab752dced30493a6672.tar.gz
postgresql-0fb0f689331cb0c00348aab752dced30493a6672.zip
Improve configure error for ICU libraries if pkg-config is absent.
If pkg-config is not installed, the ICU libraries cannot be found, but the custom configure error message did not mention this. This might lead to confusion about the actual problem. To improve this, remove the explicit error message and rely on PKG_CHECK_MODULES' generic error message. Author: Michael Banck Reported-by: Holger Jakobs Discussion: https://postgr.es/m/ccd579ed-4949-d3de-ab13-9e6456fd2caf%40jakobs.com Discussion: https://postgr.es/m/66b5d05c.050a0220.7c8ce.a951@mx.google.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index c46ed2c591a..4e279c4bd66 100644
--- a/configure.ac
+++ b/configure.ac
@@ -829,11 +829,7 @@ AC_MSG_RESULT([$with_icu])
AC_SUBST(with_icu)
if test "$with_icu" = yes; then
- PKG_CHECK_MODULES(ICU, icu-uc icu-i18n, [],
- [AC_MSG_ERROR([ICU library not found
-If you have ICU already installed, see config.log for details on the
-failure. It is possible the compiler isn't looking in the proper directory.
-Use --without-icu to disable ICU support.])])
+ PKG_CHECK_MODULES(ICU, icu-uc icu-i18n)
fi
#