aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRobert Haas <rhaas@postgresql.org>2024-08-05 11:40:29 -0400
committerRobert Haas <rhaas@postgresql.org>2024-08-05 11:41:57 -0400
commitf80b09bac87d6b49f5dbb6131da5fbd9b9773c5c (patch)
tree353896ae8f4a860c269ec705c4f1becddf4f90f1 /meson.build
parent53b2c921a0f9b56465ab65165c1909f9616ffa98 (diff)
downloadpostgresql-f80b09bac87d6b49f5dbb6131da5fbd9b9773c5c.tar.gz
postgresql-f80b09bac87d6b49f5dbb6131da5fbd9b9773c5c.zip
Move astreamer (except astreamer_inject) to fe_utils.
This allows the code to be used by other frontend applications. Amul Sul, reviewed by Sravan Kumar, Andres Freund (whose input I specifically solicited regarding the meson.build changes), and me. Discussion: http://postgr.es/m/CAAJ_b94StvLWrc_p4q-f7n3OPfr6GhL8_XuAg2aAaYZp1tF-nw@mail.gmail.com
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 21e7134d863..cc176f11b5d 100644
--- a/meson.build
+++ b/meson.build
@@ -3037,7 +3037,7 @@ frontend_common_code = declare_dependency(
compile_args: ['-DFRONTEND'],
include_directories: [postgres_inc],
sources: generated_headers,
- dependencies: [os_deps, zlib, zstd],
+ dependencies: [os_deps, zlib, zstd, lz4],
)
backend_common_code = declare_dependency(