aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Munro <tmunro@postgresql.org>2025-01-08 07:15:28 +1300
committerThomas Munro <tmunro@postgresql.org>2025-01-08 07:19:46 +1300
commitc4782c44101ef9e50daa9e1d69821d98f58057fd (patch)
tree077247da778564c49280cb415edfe517276df5ef /meson.build
parent5b291d1c9c09d75982c3270bfa61d4e822087b6a (diff)
downloadpostgresql-c4782c44101ef9e50daa9e1d69821d98f58057fd.tar.gz
postgresql-c4782c44101ef9e50daa9e1d69821d98f58057fd.zip
Fix meson detection of a couple of 64 bit builtins.
A couple of checks were missed by commit 962da900, so we would fail to detect the features. Reported-by: Юрий Соколов <y.sokolov@postgrespro.ru> Discussion: https://postgr.es/m/42C25E2A-6519-4549-9F47-6B0686E83836%40postgrespro.ru
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index fdc7b212732..cfd654d2916 100644
--- a/meson.build
+++ b/meson.build
@@ -2101,7 +2101,7 @@ __sync_val_compare_and_swap(&val, 0, 37);'''},
{'name': 'HAVE_GCC__SYNC_INT64_CAS',
'desc': '__sync_val_compare_and_swap(int64)',
'test': '''
-INT64 val = 0;
+int64_t val = 0;
__sync_val_compare_and_swap(&val, 0, 37);'''},
{'name': 'HAVE_GCC__ATOMIC_INT32_CAS',
@@ -2114,13 +2114,14 @@ __atomic_compare_exchange_n(&val, &expect, 37, 0, __ATOMIC_SEQ_CST, __ATOMIC_REL
{'name': 'HAVE_GCC__ATOMIC_INT64_CAS',
'desc': ' __atomic_compare_exchange_n(int64)',
'test': '''
-INT64 val = 0;
-INT64 expect = 0;
+int64_t val = 0;
+int64_t expect = 0;
__atomic_compare_exchange_n(&val, &expect, 37, 0, __ATOMIC_SEQ_CST, __ATOMIC_RELAXED);'''},
]
foreach check : atomic_checks
test = '''
+#include <stdint.h>
int main(void)
{
@0@