aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAndres Freund <andres@anarazel.de>2025-02-12 08:15:53 -0500
committerAndres Freund <andres@anarazel.de>2025-02-12 08:15:53 -0500
commitb64d83115cba32b3baf7bd985fc628efbc2dbc3b (patch)
treea64d5fe61b4bfd8c869d2f9e89da2ecdcbdcf03a /meson.build
parent0fc68c8421b656f2ad03e788d97ff0c59da60e6f (diff)
downloadpostgresql-b64d83115cba32b3baf7bd985fc628efbc2dbc3b.tar.gz
postgresql-b64d83115cba32b3baf7bd985fc628efbc2dbc3b.zip
meson: Fix failure to detect bsd_auth.h presence
bsd_auth.h file needs to be included after 'sys/types.h', as documented in https://man.openbsd.org/authenticate.3 The reason a similar looking stanza works for autoconf is that autoconf automatically adds AC_INCLUDES_DEFAULT, which in turn includes sys/types.h. Backpatch to all versions with meson support. Author: Nazir Bilal Yavuz <byavuz81@gmail.com> Discussion: https://postgr.es/m/637haqqyhg2wlz7q6wq25m2qupe67g7f2uupngzui64zypy4x2@ysr2xnmynmu4 Backpatch-through: 16
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1ceadb9a830..7dd7110318d 100644
--- a/meson.build
+++ b/meson.build
@@ -557,7 +557,8 @@ test_c_args = cppflags + cflags
bsd_authopt = get_option('bsd_auth')
bsd_auth = not_found_dep
if cc.check_header('bsd_auth.h', required: bsd_authopt,
- args: test_c_args, include_directories: postgres_inc)
+ args: test_c_args, prefix: '#include <sys/types.h>',
+ include_directories: postgres_inc)
cdata.set('USE_BSD_AUTH', 1)
bsd_auth = declare_dependency()
endif